[OpenAFS] Kerberos 5 / AFS / PAM

Randy Philipp randy@umbc.edu
Mon, 18 Jun 2001 11:49:53 -0400 (EDT)

I have been trying to to setup OpenAFS in a Kerberos 5 / AFS environment
and I have been running into the following problem.  The token command is
not returning the AFS ID when listing tokens after my initial login.  I
have configured PAM to use the pam_krb5afs.so module to get AFS tokens.  I
get the following response from the tokens command:

Tokens held by the Cache Manager:

Tokens for afs@umbc.edu [Expires Jun 19 11:23]
   --End of list--

I appear to have tokens, and I have access to my AFS home directory.
While after I run afslog or klog, I get the following:

Tokens held by the Cache Manager:

User's (AFS ID xxxxxx) tokens for afs@umbc.edu [Expires Jun 19 11:23]
   --End of list--

I have been using the pam_krb5 RPM that comes with RedHat 6.2, and I have
tried newer versions of this PAM module, but I still get the same error.
While this error is minor, I am concerned that I may not be configuring
PAM correctly, or I am using a non working version Kerberos.  Any help on
configuring PAM for AFS in a Kerberos 5 environment would be greatly

Randy Philipp