[OpenAFS] Aklog

Neulinger, Nathan nneul@umr.edu
Mon, 18 Jun 2001 15:11:07 -0500

If you have afs working, I have a slightly patched build that seems to work
ok for me at:


also in that area (krb5src) is our locally patched krb5 (based alot on Ken's
work, but against the krb5-current snapshots).

Feel free to grab anything you need out of there.

-- Nathan

> -----Original Message-----
> From: T. Matthew Cocker [mailto:matt@cs.auckland.ac.nz]
> Sent: Monday, June 18, 2001 3:07 PM
> To: openafs-info@openafs.org
> Subject: [OpenAFS] Aklog
> Hi
> We are trying to set up an OpenAFS cell using a mix of linux OpenAFS 
> servers (Redhat 7.1) and win2k/linux clients. So far we have 
> been able to 
> get openafs servers running with the stock kernel but we 
> cannot compile the 
> 24.2 kernel modules or the OpenAFS source again the 2.4.2-2 
> Redhat kernel 
> source. We got around this by compiling against a kernel.org 
> 2.4.4 src 
> package (we haven't tested this kernel[smp]-OpenAFS package 
> yet but will 
> soon).
> So the linux server/client side seems to be okay if we stick 
> with kaserver. 
> However we want to use Krb5 so I have been plugging away at 
> getting the 
> AFS-Krb5 migration kit to compile. So far I have managed to 
> get all but 
> aklog to compile and we have a test cell working with krb5 
> (although I have 
> tried so many things that I have forgotten what actually 
> worked) which I 
> can access using Transarcs windows client.
> Has anyone got patched src or binaries for the migration kit 
> for RedHat 
> 7.1, OpenAFS-1.0.4 and MIT Kerberos-1.2.2. I have been 
> following the "How 
> to set up AFS with Kerberos V" web pages by Martin Schulz but 
> I had to use 
> afs_int32 not int32_t (thanks to Ken for that) and am now 
> stuck at the 
> adderetable.o bit. I can't follow the Martin's web site here 
> because my 
> Makefile entries look exactly like that on the web site. Is 
> that good/bad?
> I tried compiling krb5 with the --enable-shared but that 
> broke all the 
> packages not just aklog? Also I have the Redhat supplied 
> krb5-1.2.2 client 
> programs and AFSKRB5 lib installed in a directory 
> /usr/kerberos while the 
> compiled krb5 (same version) is in 
> /usr/local/(bin/include/lib/sbin). If I 
> use the following
> ./configure --with-krb5=/usr/kerberos 
> --with-afs=/usr/src/openafs-1.0.4/dest 
> --with-krb5-obj=/usr/local/src/krb5-1.2.2/src
> I have had a lot more success using this configuration than 
> if I point 
> with-krb5 to /usr/local. Is this because the krbafs lib is 
> required by the 
> migration kit?
> I have been communicating with Ken but if someone has already 
> got this 
> working, I don't want to waste Ken's time reinventing the wheel.
> Cheers
> Matt Cocker
> _______________________________________________
> OpenAFS-info mailing list
> OpenAFS-info@openafs.org
> https://lists.openafs.org/mailman/listinfo/openafs-info