[OpenAFS] umount fails during shutdown with AFS?

pberge@stny.rr.com pberge@stny.rr.com
Tue, 26 Jun 2001 20:08:31 GMT


I have been happily running the openafs-1.0.4-24.1 client on my Linux laptop
with RedHat7.1.  I had to recompile the libafs module since the modules with the
rpm package have unresolved symbols with the pcmcia enabled kernel. The package
maintainers should probably add that module to the kernel rpm.  Email me
privately if you would like my pcmcia enabled RH7.1 libafs module.

The only problem I am having is if I run afs start (afsd running and libafs
loaded) then I get "umount /usr device is busy" when I shutdown.   The system
appears to shutdown correctly and fsck is not called after a reboot.   If I
don't start afs then the umount during shutdown works fine.

What is interesting if I do an "afs start" then "afs stop" then a shutdown I
still get the umount problem.  It seems like something afs start does causes
this umount problemn with my /usr partition.

I am connecting to an older closed source AFS server with my laptop.  I have no
idea what version ..etc since I am not the system admin.  I don't think this has
anything to do with my umount message, but who knows?  Any ideas ?