[OpenAFS] Linux Kernel 2.4.17, klog problems after source build

Ingmar Koecher koecheri@MAIL.LIB.MSU.EDU
Wed, 6 Mar 2002 17:28:49 -0500


after searching deja & the complete info archive I still can't solve the

I installed the Redhat 7.2 rpm afs client packages (on a Redhat 7.2 machine)
and everything worked fine, no problem. I can access everything I want to
access on the
AFS servers.

Today I installed another Redhat 7.2 machine and installed the new 2.4.17
kernel. Then I
couldn't start afs because no modules existed for the 2.4.17 kernel. OK I
thought, and I
downloaded the AFS source, compiled and installed it.

All the files are in /usr/local/bin ..sbin ..etc and so on (this is where
make install put them).
For compatability purposes I linked the /usr/vice/etc directory to the
/usr/local/etc directory.

Then I copied the following (text) files from the other Redhat installation

so basically the /usr/local/etc on the new machine looks exactly like the
one on the working 
machine. So the AFS daemon afsd starts successfully, and the afs directory
structure is even 
being created in the /afs directory - so I can see the directories. But now
comes the problem:

When I try to get a token with klog and type

klog -principal myusername (or if I just type klog)

then I get:   klog: error reading cell database Can't get local cell name!

Specifying the cell with the -c command line switch doesn't help either, the
same error message
pops up. The files should have the correct permission, but since I am trying
it out as root it shouldn't
matter anyhow.

I couldn't find any environment settings either, so I don't know what I am
missing here. If the afsd finds
the configuration files ok, why doesn't klog?

So basically what I am wondering is why klog can't read the cell database if
it is linked from /usr/vice/etc
(and therefor present). Where else does it look? Why doesn't it help to
specify the cell name with the -c
switch ??

I am already trying to look through the source, but I haven't found anything
yet ...

I am now wondering if I should just save the module file that was generated
during that build and add
it to the modload directory of the rpm installation - but that doesn't sound
good to me.

Thanks for any help,