[OpenAFS] Debian AFS Install Problem

fbo3@gmx.net fbo3@gmx.net
Fri, 15 Mar 2002 12:47:19 +0100


after installing kerberos (mit5) and openafs I tried to setup my first
2 Scripts for setting up a first server were installed by the
debian-package "openafs-dbserver":
 afs-newcell and afs-rootvol
Running afs-newcell works well. After afs-newcell I kinit'ed as
root and aklog'ed.

ent # kinit root
ent # aklog
ent # tokens

Tokens held by the Cache Manager:

User's (AFS ID 1) tokens for afs@alpha [Expires Mar 15 22:28]
   --End of list--
ent # bos listusers ent
bos: failed to retrieve super-user list (security object was passed a bad ticket)

?? Why do I have to use -localauth ??

ent # bos listusers ent -localauth
SUsers are: root 
ent # afs-rootvol

In order to set up the root.afs volume, you must meet the following pre-conditions:

1) The cell must be configured, running a database server with a
   volume location and protection server.  The afs-newcell script will
   set up these services.

2)  You must be logged into the cell with  tokens in
   system:administrators and with a principal that is in the susers
   file of the servers in the cell.

3) You need a fileserver in the cell with partitions mounted and a
   root.afs volume created.   Presumably, it has no volumes on it,
   although the script will work so long as nothing besides root.afs
   exists.  The afs-newcell script will set up the file server.

4) The AFS client must be running pointed at the new cell.
Do you meet these conditions? (y/n) y
You will need to select a server (hostname) and AFS
partition on which to create the root volumes.
What AFS Server should volumes be placed on? ent
What partition? [a] a
fs sa /afs system:anyuser rl
fs: You don't have the required access rights on '/afs'
Failed: 256
ent # tail -n 1 /var/log/syslog
Mar 15 12:32:42 enterprise kernel: afs: Tokens for user of AFS id 1 for cell alpha are discarded (rxkad error=19270407)

?? Does anyone know what the problem could be ??
I tried to kinit and aklog as normal user too but result of afs-rootvol was
the same.
Kerberos seems to work, I was able to telnet to this machine using krb5.

Thanks for any help.


PS: What I'm using:
 -debian sid
 -linux 2.4.18, patched with xfs-support
 -athlon processor