[OpenAFS] Win2K/XP bugs? with openafs & problems with salvager

Matthew Cocker matt@cs.auckland.ac.nz
Tue, 26 Mar 2002 08:21:37 +1200


We are in the process of moving all our network storage to Openafs with
~1.4Tb of space now coming online. So far we have had only minor problems
with the server side. A server crashed because of a power outage and when
the server came up the salvage process appeared to complete but when we
tried to move the volumes they were taken offline not moved. I ran salvage
again it completed OK according to the logs and we were able to move about
200 volumes before the vos move took the rest of the volumes offline again.
A couple more loops of salvage and move got the rest of the volumes moved.
Any ideas what was going on here.

 In windows 2000 and XP we can not save to a afs drive from acrobat 5.05
reader. We can save it locally and copy it to the drive no problems but if
we try to save it directly to the drive we get out of space errors. Also
from Jbuilder5 we can not create projects directly in afs space. You need to
create it on the local drive move it then open the project. Once it is
created it works fine and saves OK. Is there a problem with some available
space check function with the AFS client on windows.

Another problem is that if the user enters there username in uppercase they
can log into windows but they fail to get tokens. One of our programers
hacked the code and created a afslogon.dll that converts the username case
to lower case before getting tokens and problem is gone (kerberos is case
sensitive or just tokens process).