1.3.71 vs. roaming profiles (was Re: [OpenAFS] 1.3.70 and windows environment variables)

Stephen Joyce stephen@physics.unc.edu
Mon, 27 Sep 2004 16:39:57 -0400 (EDT)


I'm still having problems with this; I tried your daily build from 9/23,
however the AFS service would not even start for me with that build.

I have backed down to the 1.3.7100 release and the service starts normally

What I'm trying to do is store windows roaming profiles in AFS.  For
this, I need for an afs submount to exist before a user logs on (because
the roaming profiles are stored in
\\%computername%-afs\users\windows\username -- I cannot transition to the
\\afs\... paths at this time due to the installed base).

I have succesfully created submounts and drives using an administrative
account; logging out and back in as the administrative account works fine.

However, when I try to log in as a domain (roaming) user, I get the windows
"cannot locate your roaming profile" error.  Once logged in, the previously
admin-mapped drives do not exist (this is OK, I can "net use" via a logon
script), and the submounts DO exist.  However, they cannot be reliably
accessed by the user:

C:>net use
New connections will be remembered.

Status		Local	Remote			Network
OK			\\winho-afs\afs		Microsoft Windows Network
OK			\\winho-afs\all		Microsoft Windows Network
OK			\\winho-afs\physics	Microsoft Windows Network
OK			\\winho-afs\project	Microsoft Windows Network
OK			\\winho-afs\users	Microsoft Windows Network

C:>dir \\winho-afs\project
06/24/2004	04:01 PM	<DIR>	.
06/24/2004	04:01 PM	<DIR>	..
05/22/2000	12:13 PM	<DIR>	jim

C:>dir \\winho-afs\users
The system cannot find message text for message number 0x13d in the message
file for System.

C:>fs la \\winho-afs\users
fs:'\\winho-afs\users': code 0x19

C:>net use u: \\winho-afs\users
The command completed successfully.

C:>dir u:
The system canot find message text for message number 0x13d in the message
file for System.

Interestingly, the dir of \\winho-afs\users SUCCEEDED the very first time I
executed the command, but failed thereafter.  This is not a tokens issue;
the same user can issue the same commands on 1.2.10 clients without

On a 1.2.10 installation, the drives show as "Unavailable" in "net use",
but dir and fs commands (and roaming profiles) work as expected.

Any hints?  Any debugging output I can generate to provide more insight?

PS.  Does anyone have a "best practices" guide for using AFS in a
windows infrastructure (storing roaming profiles in AFS, etc?)  We've been
doing this for years, but figuring it out took lots of experimentation.

Stephen Joyce
Systems Administrator                                            P A N I C
Physics & Astronomy Department                         Physics & Astronomy
University of North Carolina at Chapel Hill         Network Infrastructure
voice: (919) 962-7214                                        and Computing
fax: (919) 962-0480                               http://www.panic.unc.edu

The only thing worse than no documentation is incorrect documentation.

On Thu, 23 Sep 2004, Jeffrey Altman wrote:

> Stephen Joyce wrote:
> > Jeffrey,
> >
> > Sorry if this has been covered already, but then what's the proposed
> > solution for those of us who are storing roaming profiles in AFS?  Worked
> > fine with 1.2.x but from what I read below (and what I'm seeing in real
> > life), 1.3.71 breaks this.
> Please try the current daily build and see if it solves your problem.
> If not, I need a better understanding of what you are doing that is not
> working.  With the current daily builds, the "submounts" registry values
> are expanded if they are of type REG_EXPAND_SZ.
>    /afs/athena.mit.edu/user/j/a/jaltman/Public/OpenAFS/
>    \\afs\athena.mit.edu\user\j\a\jaltman\Public\OpenAFS\
>    http://web.mit.edu/~jaltman/Public/OpenAFS/
> Jeffrey Altman