[OpenAFS] afsd: Error -1 in basic initialization

Derrick J Brashear shadow@dementia.org
Tue, 7 Feb 2006 23:41:45 -0500 (EST)

On Wed, 8 Feb 2006, Maurizio Santini wrote:

> I've compiled and installed successfully openafs-1.4.1-rc6 on a RedHat
> 7.3 with kernel-2.4.32 but when I run afsd I get:
> afsd: Error -1 in basic initialization.

afsd isn't going to work until you get a working kernel module.

> I have the kernel compiled with CONFIG_NOHIGHMEM set and I wonder if
> that is the problem.  I've also tried openafs-1.2.13 but again the afs
> won't start.
> Both
> "insmod /usr/local/openafs/lib/openafs/libafs-2.4.32.mp.o" (openafs-1.4.1-rc6) and "insmod /usr/vice/etc/modload/libafs-2.4.32.mp.o" (openafs-1.2.13) leads to the same error:
> /usr/vice/etc/modload/libafs-2.4.32.mp.o: unresolved symbol kunmap_high
> /usr/vice/etc/modload/libafs-2.4.32.mp.o: unresolved symbol
> highmem_start_page
> /usr/vice/etc/modload/libafs-2.4.32.mp.o: unresolved symbol kmap_high
> /usr/vice/etc/modload/libafs-2.4.32.mp.o:

That suggests somehow your kernel headers that AFS was compiled against 
don't match the kernel you're running.

Compile a module against the headers from the running kernel, and try