[OpenAFS] rc7 - aklog -m isn't working?

Robbie Foust rfoust@duke.edu
Fri, 17 Feb 2006 09:46:38 -0500

For some reason I can't reproduce the problem this morning.  I took the 
k524init back out of my script and everything is working fine.  I did 
upgrade the kfw install on that system to v3.0 last night (I just used 
the .zip binaries, and updated the system path), so maybe something in 
there fixed my problem?

I'll do some more debugging and post back here if I have any more problems.


- Robbie

Jeffrey Altman wrote:
> Microsoft's MSI technology performs upgrades by removing all traces of
> the original installer and then applying the new one.   There is no
> state that we can preserve.  Values stored in the Services keys must
> be backed up manually and restored if you want them to be preserved.
> Other options are to apply a transform to the MSI you wish to install
> including the keys you want to have set.
> -m means use krb524d.  What does "aklog -5 -m -d" report?
> Jeffrey Altman
> Robbie Foust wrote:
>>Just updated to rc7 on a w2k3 terminal server, and now it seems that
>>aklog -m is no longer doing the 524 conversion.  If I run k524init from
>>the kfw package, and then aklog (-m) it works.
>>I don't think a registry setting change would cause this, would it?  The
>>reason I ask is that I ran the install again as a repair (for an
>>unrelated reason) and it changed all the registry values back to
>>defaults.  It didn't keep the values I selected during the original
>>install. I went back and changed them manually, or at least the ones I
>>knew about. :-)  BTW, I'm using the msi installer..
>>- Robbie

Robbie Foust, CISSP, A+
Duke University