[OpenAFS] OpenAFS Windows client will not map drives

Gordon Bowersox gbowerso@sbgnet.com
Fri, 03 Mar 2006 12:38:22 -0500

Here is a WAG for you to try.  May cause 'unexpected results' (but a 
good test)

Go to 'My Network Places'
On menu Choose 'Advanced'
	'Advanced Settings...'

Tab in Window - Adapters and Bindings
	Client for Microsoft Networks
		NWLink IPX/SPX/NetBIOS Compatible Transport Protocol

Also consider munging up the 'Provider Order' under

Tab - Provider Order

Jeffrey Altman wrote, On 3/3/2006 12:12 PM:
> I have heard of other organizations having problems with both Novell
> and OpenAFS clients on the same machines.  I have not had access to
> such a configuration to be able to debug it.
> If "NET USE" does not work to map the drive then none of the drive
> mapping panels in the AFS tools will work either.  The error messages
> that come from NET USE are going to be the ones that matter the most.
> You can follow the troubleshooting instructions in the OpenAFS Release
> Notes (Start Menu->Programs->OpenAFS->Documentation) to capture logs
> of what the AFS Client Service is seeing.  If you are able to obtain
> tokens and list them, then you are communicating successfully with
> the AFS SMB service.  Start with mapping a drive to
> \\SPH-2008-08-AFS\ALL.  If you can't do that, it may be the Novell
> client is altering the behavior of the Windows CIFS client such that
> the AFS SMB server cannot respond.
> Jeffrey Altman
> Sean Caron wrote:
>> I'm trying to install the OpenAFS client on some Windows XP Pro
>> workstations and I am finding that for some reason, I am not able to map
>> drives in the AFS heirarchy to Windows drive letters.
>> The systems are set up running XP Pro with the Novell client set up for
>> single sign on. Protocols installed are: NWLink NetBIOS, NWLink
>> IPX/SPX/NetBIOS Compatible Transport Protocol, TCP/IP. MIT Kerberos for
>> Windows 3.0 is installed and working perfectly (getting tickets and so
>> forth). I install the OpenAFS client 1.4.0 with default settings EXCEPT
>> without the loopback adaptor because it seems to break the Novell
>> client. I have things set up such that it is the OpenAFS client that
>> prompts the user to sign into Kerberos/AFS, not the MIT Kerberos client
>> itself.
>> I log into a workstation and I get the dialog box from OpenAFS prompting
>> for my username and
>> password. I can type in my username and password and it apparently logs
>> in successfully and obtains
>> tickets.
>> BUT, although everything seems to be working well, I cannot map drives
>> at all!
>> If I just go to Start->Run and type something like, for example,
>> \\SPH-2002-08-AFS\sph.umich.edu\some\path\here
>> Windows will pop up a window as usual, and I can navigate the AFS
>> directory tree, no problems. But if
>> I actually try to set up some mapping points, I get a number of strange
>> errors.
>> (1) If i try to use NET.EXE to set up the mappings, say, for my home
>> directory,
>> NET USE \\sph-2002-08-AFS\sph.umich.edu\user\s\scaron g:
>> I get a "system error 67" from Windows: "the network name cannot be found".
>> (why? when Windows can obviously resolve the network name for browsing,
>> as above...)
>> (2) If i try to use the AFS system tray program or control panel to
>> configure a mapping,
>> I get an error: "AFS was unable to map the network drive to the
>> specified path in AFS. Check to make
>> sure that the drive letter is not currently in use. Error: 0x00000043"
>> (what does Error 0x00000043 even indicate? I see no mention of it on the
>> Web or in the docs)
>> Does anyone have any idea why this would occur? I'm running out of
>> things to try. The account that I
>> am using IS a member of the "AFS Client Admins" group. I am of course
>> trying to map to a drive letter
>> that is available. I've tried changing the name of a machine to
>> something that doesn't contain any
>> nonalphabetic characters (only letters and numbers). I've messed with
>> NetBIOS over TCP/IP settings.
>> I've tried installing Microsoft File & Print Sharing services in the
>> networking control panel (this actually
>> seems to break the client even more). I've tried it with the loopback
>> client (breaks Novell) and without
>> the loopback client (works, as above, but I just can't map drives). I've
>> tried the beta client 1.5.0 and
>> it does the same thing.
>> Does the OpenAFS/Windows client have some sort of dependency that I am
>> not aware of? The docs,
>> are, as everyone is probably fully aware, pretty lousy, and don't really
>> indicate what OpenAFS really
>> needs to run properly in terms of Windows configuration, protocols, etc.
>> I would greatly appreciate any suggestions anyone might have.
>> Thanks!
>> Sean Caron
>> Associate Systems Administrator
>> University of Michigan School of Public Health
>> scaron@umich.edu <mailto:scaron@umich.edu>
>> 1-734-763-4206