[OpenAFS] porting to Linux ARM

Albrecht Gebhardt albrecht.gebhardt@uni-klu.ac.at
Sun, 3 Sep 2006 23:47:44 +0200

Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

On Sun, Sep 03, 2006 at 06:59:58AM -0400, Marcus Watts wrote:
> Albrecht Gebhardt <albrecht.gebhardt@uni-klu.ac.at> writes:
> > From: Albrecht Gebhardt <albrecht.gebhardt@uni-klu.ac.at>
> > To: openafs-info@openafs.org
> ...
> > bosserver, vlserver, fileserver, volserver, ptserver can be compiled
> > and are running (but untested if they really work, testing this would
> > easier with a running openafs client).
> Actually most of these you can test without a working cache manager.
> bosserver doesn't talk to cache managers at all, just bos.
> ptserver talks to your fileserver and you (pts), but not
> 	to your cache manager.
> volserver talks to you (vos), never to the cache manager.
> vlserver talks to your cache manager and you (vos).
> ptserver is usually a good thing to start with, since it doesn't depend
> on anything else (you don't even need bosserver to run it).
> If you already have a working afs environment, then you have
> a client machine with cache manager & friends.  A 386 based
> client machine will work fine with your arm based server.
> You probably don't want to run the cm on your server anyways.

Does this mean that I could start setting up a completely new cell
for testing without a cache manager?=20

Meanwhile a tried the follwing:
* fresh install of openafs-fileserver package (no dbserver).
* manually configured to be part of my existing cell
* mounted a /vicepa partition=20
* bos create -server servername -instance fs  -type fs \
  -cmd /usr/lib/openafs/volserver  /usr/lib/openafs/salvager -localauth

  it somehow complained, but it worked (I guess it complained because I
  tried it several times, so my db server (i386) already knew the new

* I could create new volumes on the arm server, either running "vos
  create" on the i386 or arm side
* I see the volumes/partitions with "vos listvol" / "vos listpart", they
  appear in my voldb (vos listvldb)
* I can add replicas.
  But when I try to "vos release" them, it complains:
root@pi[root]# vos release testvol2 -localauth
Volume needs to be salvaged
Error in vos release command.
Volume needs to be salvaged

and the FileLog on the arm server says:
Sun Sep  3 23:25:32 2006 VAttachVolume: Error reading diskDataHandle
vol header /vicepa//V0536871001.vol; error=3D101
Sun Sep  3 23:25:32 2006 VAttachVolume: Error attaching volume
/vicepa//V0536871001.vol; volume needs salvage; error=3D101

Starting a salvage run works:
bos salvage -server arm-machine -all -localauth
but doesnt help

I can add mountpoints, but access results in "Connection timed out" or=20
"No such file or directory", FileLog says:
Sun Sep  3 23:27:06 2006 GetBitmap: addled vnode index in volume
testvol3; volume needs salvage
Sun Sep  3 23:27:06 2006 VAttachVolume: error getting bitmap for
volume (/vicepa//V0536871006.vol)

=2E.. so far. I think I have to repeat the tests more systematically with c=
leaning up their
traces in my afsdb. So I should "delete/zap" the test volumes? and how
can I remove the fileserver from my db?


// Albrecht Gebhardt          Tel.: (++43 463) 2700/3118
// Institut fuer Mathematik   Fax : (++43 463) 2700/3198
// Universitaet Klagenfurt    mailto:albrecht.gebhardt@uni-klu.ac.at
// Universitaetsstr. 65       http://www.math.uni-klu.ac.at/~agebhard
// A-9020 Klagenfurt, Austria
// GPG PK: http://www.math.uni-klu.ac.at/~agebhard/agebhard.asc
// GPG FP: F46F 656E E83C 9323 CE30  FF8F 9DBA D1A3 B55A 78A6

Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: Digital signature
Content-Disposition: inline

Version: GnuPG v1.4.1 (GNU/Linux)