[OpenAFS] OpenAFS 1.4.x on SuSE 10.1 and rlim error

Jeffrey Hutzelman jhutz@cmu.edu
Mon, 18 Sep 2006 19:20:38 -0400

On Monday, September 18, 2006 04:16:53 PM -0700 Russ Allbery 
<rra@stanford.edu> wrote:

> Lewis, Dave <LEWIS@NKI.RFMH.ORG> writes:
>> I saw previous posts dealing with this issue but don't know if anyone
>> has a solution that works yet. I tried compiling openafs 1.4.1 on suse
>> 10.1 (single processor, 32-bit, Compilation
>> aborted with:
> There have been lots and lots of solutions that work.  The error message
> is extremely generic and means that, basically, OpenAFS was unable to find
> kernel headers that correspond to the kernel against which you're
> building.  In order to see what the problem really is, you have to look
> at the config.log output.
>> In previous posts on this issue I saw mention of a patch for ticket #
>> 34561. Is it supposed to fix the rlim error? I applied the patch but
>> still got the error. (I tried both the original patch and the June 30
>> update.)
> It's not useful to look for patches based on this particular error because
> there is no "rlim error."  That error message means "compiling with your
> kernel headers failed" and there are literally hundreds of different
> things that could be wrong.

... but often, the problem is that the configure tests utterly failed 
because configure was unable to install your kernel headers, perhaps 
because you haven't actually installed them.

Do you have a kernel-src or kernel-devel RPM installed?