[OpenAFS] dual database configuration

Marcus Watts mdw@spam.ifs.umich.edu
Tue, 03 Jul 2007 06:25:24 -0400

> Date:    Mon, 02 Jul 2007 20:48:44 +0200
> To:      openafs-info@openafs.org
> From:    =?ISO-8859-1?Q?G=E9rald_Macinenti?= <gerald.macinenti@letitwave.fr>
> Subject: [OpenAFS] dual database configuration
> Hi,
> I've tried to follow the AFS Quick Start Guide for configuring two=20
> database servers for a unique Cell, but it doesn't seam to work perfectly=
> .
> What I've done:
> configured a full-featured server with Kerberos,AFS databse and file=20
> server: worked OK, configured AFS client on the machine and on a second=20
> machine with success.
> Then I configured a file server on the second machine, it was visible=20
> and usable from the first machine (after KeyFile copy), could do vos=20
> addsite and so on with no problem.
> At last, I added this second machine in CellServDB on both machines and=20
>   created the buserver, ptserver and vlserver on this second machine.=20
> Did a (few) reboot of both machines, the first has the lowest IP, when=20
> the second boots, I see a "Fileserver ready" on the first one which=20
> seams a good sign, but I can't have any client working with this=20
> configuration:  "Can't mount AFS...", did I forget something? (I've=20
> tried with only the first server and both servers in CellServDB of=20
> clients...)
> Cheers
> --=20
> G=E9rald Macinenti - Admistrator

Does root.afs exist?  root.cell?  Have you tried using "tcpdump" or related
when the cache manager tries to mount /afs?  What server(s) and ports was
it talking to, and did anything come back?

				-Marcus Watts