[OpenAFS] Initial server setup

Martin Lütken mlu@danware.dk
Tue, 20 Mar 2007 17:33:14 +0100

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
  <meta content="text/html;charset=ISO-8859-1" http-equiv="Content-Type">
<body bgcolor="#ffffff" text="#000000">
ted creedon wrote:
<blockquote cite="mid002301c76b0a$68d91290$9501010a@attu1" type="cite">
  <pre wrap="">Stick to SuSe 10.2, it works fine here. (8.x, 9.x, 10.0, 10.1 10.2). When
you reinstall SUSE, intall the krb5 package but leave all the afs rpm's
out, including the krb-afs, the afs module, etc. 

Set up stock krb5.ini, if you can wait a few days I'll add in the scripts I
use to set up a cell from scratch including a slightly revised Ken Hornstein
howto for the initial key file setup. It uses Transarc paths to be
consistent with the IBM docs.

I use an internal wiki to archive all the hints and tricks that are not in
the docs.

No need to shout.. Won't help.


-----Original Message-----
From: Martin L&uuml;tken [<a class="moz-txt-link-freetext" href="mailto:mlu@danware.dk">mailto:mlu@danware.dk</a>] 
Sent: Tuesday, March 20, 2007 8:52 AM
To: <a class="moz-txt-link-abbreviated" href="mailto:tcreedon@easystreet.com">tcreedon@easystreet.com</a>
Subject: Re: [OpenAFS] Initial server setup

ted creedon wrote:
  <blockquote type="cite">
    <pre wrap="">What OS? At one time I had a LaTex Quick Beginnings that was for only the
selected operating system.

  <pre wrap=""><!---->Tried compiling latest sources on SUSE 10.2 (not using transarc).
Ran into problems when trying to run:
'bos create myserver kaserver simple /usr/local/libexec/openafs/kaserver
- cell mycellname -noauth

After some time I gave up that approach. Installed gentoo in an effort
to follow the gentoo afs server installation guide. I do come a little
further but when I get to the point where i need to run:

kas -cell &lt;cell name&gt; -noauth
ka&gt; create afs
Then after re-entering password I keep getting :
'Creating user afs  : [____] server or network not responding'

Followed some threads about this trying to do the suggested fixes with no


  <blockquote type="cite">
    <pre wrap="">If you want I'll try to find it or I can send you the LaTex sources.

Use krb5 and ntp time which for QBG are the major changes.


-----Original Message-----
From: <a class="moz-txt-link-abbreviated" href="mailto:openafs-info-admin@openafs.org">openafs-info-admin@openafs.org</a>
  <pre wrap=""><!---->[<a class="moz-txt-link-freetext" href="mailto:openafs-info-admin@openafs.org">mailto:openafs-info-admin@openafs.org</a>]
  <blockquote type="cite">
    <pre wrap="">On Behalf Of Martin L&uuml;tken
Sent: Tuesday, March 20, 2007 8:16 AM
To: <a class="moz-txt-link-abbreviated" href="mailto:openafs-info@openafs.org">openafs-info@openafs.org</a>
Subject: [OpenAFS] Initial server setup

I tried for a couple of weeks now to set up an openAFS server.
I read through the IBM documentation and surfed the net.
It seems the IBM documentation is somewhat outdated or ?
Should I still use 'kasserver' . Sometimes I find statement saying not
to but IBM documentation use that.

I know I shoould perhaps ask more specifically on my current problem,
but I really have tried a lot and sometimes I get a little step forward

OpenAFS-info mailing list
<a class="moz-txt-link-abbreviated" href="mailto:OpenAFS-info@openafs.org">OpenAFS-info@openafs.org</a>
<a class="moz-txt-link-freetext" href="https://lists.openafs.org/mailman/listinfo/openafs-info">https://lists.openafs.org/mailman/listinfo/openafs-info</a>

  <pre wrap=""><!---->

Was not meant as shouting. Just thought I asked a lot of not very
precise questions, so the capital letters was only meant as enhancing
(summing up) what I really was trying to ask :)<br>