[OpenAFS] Compiling openafs 1.4.2 on RHEL5

Marsh, Alexander ajmarsh@umich.edu
Thu, 22 Mar 2007 11:29:01 -0400


I am attempting to compile openafs 1.4.2 on RHEL 5 as a client machine.
The configure stage worked:

./configure --with-afs-sysname=3Di386_linux26 --enable-transarc-paths
--enable-redhat-buildsys =

Make and make dest also worked fine.  However my machine is running a
smp kernel=20

uname -a
Linux ipa  2.6.18-8.1.1.el5xen #1 SMP Mon Feb 26 21:05:12 EST 2007 i686
i686 i386 GNU/Linux

The only thing I find in the modload directory was
libafs-2.6.18-8.1.1.el5.ko.  Try as I might I can not get it to build me
a smp version.  I have tried just renaming the file to
libafs-2.6.18-8.1.1.el5xen.mp.ko with no luck.=20

When I try to start afs I get:

Failed to load AFS client, not starting AFS services.

Looking in the logs I find:

Mar 22 11:22:32 ipa kernel: libafs: disagrees about version of symbol

I realize not to many people have attempted to install openafs on RHEL5
as it has been out less than a week, but I would greatly appreciate any
help or guidance you can provide.

Thanks in advance,


Alexander J. Marsh | desk 763.0246  cell 368.3839
Unix  Systems  Administrator  LIT  Core  Services