[OpenAFS] openafs w/ amd64 kernel and 32bit user space

Sean O'Malley omalleys@msu.edu
Mon, 26 Mar 2007 19:10:38 -0400 (EDT)

On Fri, 23 Mar 2007, Carson Gaspar wrote:

> And sadly many user-land pieces still are not 64-bit clean. I know that
> I've had to fall back to 32-bit mode for several apps on my Solaris x86
> server, as I didn't have the time & energy to fix the crappy source.

I ran into the same problem =) I started hacking AFS to get userland stuff
working, but put a dent in my head banging off the wall. I did manage to
get it to compile, and started in with lint but that was about as far as I
got. :)

It is one of those things where everyone if they get time should add a
hack here and there to make it 64-bit safe when they see something. It
isnt going to get done in a one weekend hack-a-thon until more is cleaned

One of the bigger problems I ran into was because stuff is compiled more
then once, you don't necessarily see the error right away. It gets lost in
the rest of the compiler warnings that might be come from a different
section of the compile. (just because it compiles cleanly doesnt mean it
works and vice versa.)

  Sean O'Malley, Information Technologist
  Michigan State University