[OpenAFS] Can't create volume on Solaris 10

Steven Jenkins steven.jenkins@gmail.com
Wed, 6 Aug 2008 13:58:44 -0400

On Wed, Aug 6, 2008 at 11:03 AM, Daniel Debertin <debertin@msi.umn.edu> wrote:
> Hi,
> I'm following the quickstart guide from openafs.org. Everything seems
> to work fine until the following command:
> afs0# vos create afs0 /vicepa root.afs -cell msi_afs -noauth
> Could not change quota, continuing...
>   : No such file or directory
> Failed to end the transaction on the volume root.afs 536870912
> : No such file or directory
> Error in vos create command.
> : No such file or directory
> I have /vicepa (just regular UFS) mounted with "-o nologging,quota",
> and have quotas enabled on that filesystem, though I have also tried
> it without quotas with the same result. I'm using version 1.5.51.
> Any ideas as to what I'm doing wrong? Let me know if you need more
> information.

That's odd.  I'd do a 'vos examine root.afs' to verify the volume is
there and then a manual 'vos setfields' to set the quota if it's
present.  It looks like the volume may not have gotten created,

If you have FileLog, VolserLog, and VLLog, those would be useful, as
they may contain some hints as to why the create failed.

Steven Jenkins
End Point Corporation