[OpenAFS] rpm failure on opensuse 10.3

Derrick Brashear shadow@gmail.com
Fri, 1 Feb 2008 13:33:40 -0500

On Feb 1, 2008 12:44 PM, David Bear <david.bear@asu.edu> wrote:
> Everything I thought I knew has just been invalidated about getting openafs
> running on Suse. Yesterday, kernel updates on my opensuse 10.2 machine forced
> a reinstall of openafs. Eventually it worked once I figure out it was not
> reading the same configuration files.
> Now, I am attempting to install using the same rpm on opensuse 10.3. I do have
> the kernel source, and I have done make clone-config make prepare make
> module_prepare. But when I attempt to
> rpm -U openafs-kmp-default-1.4.6_2.6.18.2_34-4.1.i582

well, that appears to be for

> I get
> error: Failed dependancies:
>   kernel(vmlinux) = 9f092688ebb50b27 is needed by ...
> I am assuming that this rpm has ties to a specific kernel -- even more
> specific than a 2.6 kernel. The rpm install of this afs worked on a 2.6.18..
> kernel yesterday. Today, it is failing on a kernel. Yuck.
> is not 2.6.18-whatever, so...