[OpenAFS] Problems using openafs-1.4.6 client on AMD64 architecture

Dominik Juergens d.juergens@tu-bs.de
Thu, 21 Feb 2008 15:02:51 +0100

Derrick Brashear wrote:

> On Thu, Feb 21, 2008 at 5:23 AM, Dominik Juergens <d.juergens@tu-bs.de> wrote:
>> Hi all,
>>  I have finally solved my issue by activating AFS_DYNROOT in
>>  /etc/openafs/afs.conf.client. Now I get:
>>  drwxrwxrwx   3 root root  2048 2007-09-03 14:04 tu-bs.de
>>  instead of:
>>  ?---------  ? ?      ?       ?                ? tu-bs.de
>>  I have not found the problem really, because the same kernel on an other
>>  machine (without recompilation) did not have this issue.
> And the other machine was 32, not 64, bits, yes?
No at the end I really found this issue to be "machine dependent", not 
architecture dependent.
One single machine did only work with the '32 Bit afs-kernel' all others 
(also with the same libraries) worked.
I switched on the dynamic root flag on that single machine and the 
problem seems to be solved, at least
we have stable access to the AFS now.

The problematic machine is a IBM X3650 server, the others are some 
Supermicro machines; I do not think that it has anything to do with that,
but the facts tell a confusing story. I tried a dozen of combinations of 
kernels (2.6.22-2.6.24) and afs versions
(stable and development) with the same result, they work only in i386 
version on this machine; on all others the
x86_64 kernel worked without a problem...
Sometimes software seems to have ghosts inside ... I don't know ...
At least our productive machine is now up and running, the same problem 
does not exist on another node.
> Traverse deeper.
> I doubt you're done
I knock on woods ;-)

Best regards