[OpenAFS] Weird conflict between openafs kernel module and nvidia driver on Ubuntu

Charles Curley charlescurley@charlescurley.com
Thu, 6 Nov 2008 17:29:59 -0700

Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

On Thu, Nov 06, 2008 at 02:58:49PM -0800, Russ Allbery wrote:
> "Karl M. Davis" <Karl.Davis@ridgetopgroup.com> writes:
> > I just opened this bug on Launchpad last night:
> > https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-177/+=
> > =20
> > Screwy as hell, seems to me.
> > =20
> > Anyone have any ideas what might be up with it?
> The only thing I can think of is some sort of IRQ conflict between your
> video and your networking, although that's really a stretch.

Curiouser and curiouser.

I take it everything worked fine under Ubuntu 8.04. If so, then I
doubt it's any bios setting.

8.04 uses the 2.6.24 kernel, 8.10 the 2.6.27. Unless there's been a
regression, I wouldn't think the new kernel would cause a problem. The
kernel has been perfectly capable of managing interrupts.

The PCI spec requires the OS to chain interrupts so that multiple
devices and their drivers can share an interrupt. And Linux has been
doing that correctly for years. So there's no real reason to require
that they be on separate IRQs.

Have you tried removing the nvidia driver completely and running the
AFS module? Anything interesting in /proc/interrupts?


Charles Curley                  /"\    ASCII Ribbon Campaign
Looking for fine software       \ /    Respect for open standards
and/or writing?                  X     No HTML/RTF in email
http://www.charlescurley.com    / \    No M$ Word docs in email

Key fingerprint =3D CE5C 6645 A45A 64E4 94C0  809C FFF6 4C48 4ECD DFDB

Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: Digital signature
Content-Disposition: inline

Version: GnuPG v1.4.6 (GNU/Linux)