[OpenAFS] set_pag hangs

Loren M. Lang lorenl@north-winds.org
Mon, 17 Nov 2008 11:50:18 -0800

Content-Type: text/plain
Content-Transfer-Encoding: quoted-printable

I left my Ubuntu Linux 8.04 Workstation logged in over the week-end and
found the computer completely hung when I came in Monday morning.  I
assumed this was just due to our use of Kerberos authenticated NFS
mounted home directories and rebooted the computer.  It appeared to boot
fine, but when I logged in I was given a blank screen.  The log-in was
successful, but no desktop appeared.  After switching to the console, I
saw that GDM had run krenew -t -- gnome-session, but gnome-session had
not been executed.  krenew was using 100% of the CPU and I could not
kill it even using SIGKILL.  I restarted gdm and tried to log in a
second time with the same results.  I then tried running krenew and
krenew -t from the console as a normal user.  Both commands succeeded
with no error, but when I ran krenew -t -- ls, it hung with no output.
Looking at the kernel logs, I found one relavent line:

[  170.202812] afs_pag_wait() PAG throttling triggered, pid 7641... sleepin=
g.  sleepcnt 0

Pid 7641 is the initial krenew process which hung.  After rebooting I
had no trouble.
Loren M. Lang

Public Key: ftp://ftp.north-winds.org/pub/lorenl_pubkey.asc
Fingerprint: 10A0 7AE2 DAF5 4780 888A  3FA4 DCEE BB39 7654 DE5B

Content-Type: application/pgp-signature; name=signature.asc
Content-Description: This is a digitally signed message part

Version: GnuPG v1.4.6 (GNU/Linux)