[OpenAFS] Problem with OpenAFS on Vista x86

Jason Edgecombe jason@rampaginggeek.com
Wed, 31 Dec 2008 20:00:28 -0500

Paul Accisano wrote:
> Jason Edgecombe wrote:
>> Paul Accisano wrote:
>>> Jason Edgecombe wrote:
>>>> Paul Accisano wrote:
>>>>> Greetings all,
>>>>> I'm trying to get OpenAFS working on my Vista laptop, and it's 
>>>>> giving me a serious headache.  The installation went okay, but 
>>>>> when I try to get tokens, I get the following error message:
>>>>> -- The AFS Client was unable to obtain tokens as [username] in 
>>>>> cell [cell address].
>>>>> -- Error 11862791 (AFS service may not have started)
>>>>> The service is definitely running, according to the client 
>>>>> window.  If enter the wrong password, I get a "password incorrect" 
>>>>> error, so it's at least recognizing my account.  One thing I think 
>>>>> may be related to the problem: at the top of the client window, it 
>>>>> says
>>>>> -- Currently logged on to Windows Networking as ""
>>>>> In an older version, (which I tried installing for the hell of 
>>>>> it), it says
>>>>> -- Currently logged on to Windows Networking as "(unknown)"
>>>>> where as on my XP box, it correctly lists my username.  I hope 
>>>>> this helps.  This is really driving my nuts; I've googled and 
>>>>> googled but I can't find a solution...  Can anyone give me some 
>>>>> advice?
>>>> Hi Paul,
>>>> What program are you using to authenticate? Are you authenticating 
>>>> at the windows logon screen, using afscreds (the program with the 
>>>> yellow lock icon), or  Kerberos Network Identity manager ( the 
>>>> program with the cube icon)?
>>>> If you aren't using the Kerberos Network Identity Manager, please 
>>>> try to login using Network Identity Manager to see if the outcome 
>>>> changes.
>>>> Sincerely,
>>>> Jason
>>> Hi Jason,
>>> I'm using the AFSCreds.  Unfortunately, I'm not sure I'll be able to 
>>> use the Kerberos Network Identity Manager.  The AFS cell I'm trying 
>>> to connect to is that of my college, and I'm not sure they support 
>>> Kerberos (if there's a difference; I'm a bit new to this).  I tried 
>>> installing it, but it asks me for a username and "realm", the latter 
>>> of which I don't know.  I tried entering the same address as the AFS 
>>> cell, but it didn't seem to like that...
>> Hi Paul,
>> In the future, please CC to the list.
>> FYI, the realm name is usually the same as the cell name. Have you 
>> edited the krb5.ini file at all?
>> can you open a windows explorer window and access 
>> \\afs\yourcollegecell.edu ?
>> Jason
> Sorry about that, I realized I forgot to CC the list right after I hit 
> send...
> When I install Kerberos, it asks me for a configuration file.  I don't 
> have one, so I select "User packaged confirmations files for the 
> ATHENA.MIT.EDU realm".  That can't be good...  After it installs, I 
> hit "obtain new credentials" where it asks for a username and realm.  
> After I enter my username and the cell address, it shows "Cannot 
> resolve network address for KDC in requested realm." and "OK" is grayed.
> Trying to access the address via explorer yields the familiar "Windows 
> cannot access \\afs\..." dialog.

Can you access \\afs\openafs.org in windows explorer? If not, then the 
client isn't working properly. unauthenticated AFS access should just 
work. After that's working, then focus on authentication.