[OpenAFS] Can't get AFS tokens on Windows 7 RC 32-bit

Johnny jarpublic@gmail.com
Tue, 16 Jun 2009 17:23:56 -0400

I am new to the list, and I have tried searching the archives and
google but haven't found anything on my situation. I have been using
Windows 7 beta on my non production home pc and laptop for a few
months. I am using Kerberos 3.2.2 with OpenAFS 1.5.60. My laptop is
running the 64-bit OS and my desktop is running the 32-bit OS. I had
everything working with Network Manager and OpenAFS on both machines
when I was ruinning the Windows 7 beta builds. Recently I upgraded and
did clean installs with the Windows 7 RC. On my 64-bit laptop
everything is working fine. On my 32-bit desktop I have been unable to
get AFS tokens. I realize that this is an unreleased OS, but I was
hoping I could get this working since I had it working with the beta
and it is working on my laptop.

When I try using network manager it gets my kerberos v5 tickets but it
fails to obtain afs tokens. When I try from the command line I get the
following (I removed my personal info).

Password for #####@CSAIL.MIT.EDU:

C:\>aklog -d
Authenticating to cell csail.mit.edu.
Getting v5 tickets: afs/csail.mit.edu@CSAIL.MIT.EDU
Getting v5 tickets: afs@CSAIL.MIT.EDU
About to resolve name #####@CSAIL.MIT.EDU to id
Id #####
Set username to #####@CSAIL.MIT.EDU
Getting tokens.
aklog: unable to obtain tokens for cell csail.mit.edu (status: 11862791).

I have tried to get logs by running "fs trace -on" but that fails with
the following:

fs: AFS service may not have started.

When I go in and check the services from windows it says that the
OpenAFS service is running. Stopping it and restarting it has no
effect. Any help on tracking down the cause and getting this working
would be greatly appreciated.