[OpenAFS] Configure AFS server for Windows: failed to get token for admin

Xiong Jiang linuster@gmail.com
Sun, 3 May 2009 01:24:36 -0700

Hi there,

I am trying the quick start wizard to configure AFS server on Windows
XP. It is not officially supported but i'd like to try. I got problem
when getting principals and credentials for the admin account. On the
linux box, the admin account is root/admin@jiang.home. I am not sure
what I should set in the administrative account page of the wizard.
The default name is "admin", I also tried "root/admin", "root.admin",
but it fails for the same error.

Do you know what could be wrong here? My openAFS is 1.5.59.


The error log is:

Configuring server

01:16:29 05/03/09:  Getting CellServDB from host

01:16:29 05/03/09:  mytv.home

01:16:29 05/03/09:  Putting this host in cell 'jiang.home'.

01:16:29 05/03/09:  Starting the bos server in no auth mode.

01:16:30 05/03/09:  Getting credentials in cell 'jiang.home' as admin 'admin'.

01:16:30 05/03/09:  Getting handles to the cell and the config library.

01:16:30 05/03/09:  Opening a non-NULL cell handle to use with the
server config library handle.

01:16:30 05/03/09:  Getting tokens in cell jiang.home for user 'admin'.

01:16:58 05/03/09:  Failed to get tokens for the specified cell:  2c112.

01:16:58 05/03/09:  Error 0x2c112 has occurred: Ubik Call failed.

01:17:00 05/03/09:  Configuration has failed.