[OpenAFS] /afs area is hanging

Felix Frank Felix.Frank@Desy.de
Tue, 5 May 2009 07:46:38 +0200 (CEST)

On Mon, 4 May 2009, Mark Henry wrote:

> I tried the -fakestat-all option and it did not work.


> I have searched /var/log/messages.  I have checked the config files.  User
> authentication works fine (even when the system is hanging).  If I run the
> command 'ls -l /afs' that window is hung (or any other command that
> references afs).  If an afs user logs in when the system is in a bad state
> the session immediately hangs because it can't cd to the afs home dir.  I
> don't know what to do other than reboot.  Can someone tell me what else to
> try to find out why this system is hanging?  Thanks,

You can find out just which call gets stuck by issuing an
'echo t >>/proc/sysrq-trigger'. Call traces for all processes can then be
found in dmesg. The broken processes are probably in a D state.

This will probably not identify the root cause, but may give a clue about
what's going on.

  - Felix