[OpenAFS] /afs area is hanging

Mark Henry mark.henry@infoprint.com
Wed, 13 May 2009 09:16:45 -0600

> that may well be related to the problem. what cron jobs do you have?

> Derrick

This is a happy day.  Derrick it looks like your skills have pointed us to the
solution.  I mentioned that we use a loopback device to mount our afs cache
filesystem.  That device was /dev/loop0.  Well, after the direction that you
gave us we found that /dev/loop0 was also being used as a method of restricting
font cache for a different app.  When the app would run the afs cache was
getting clobbered and the afs hang would follow.  We have moved the afs cache
to a new place now and it looks like this problem has been solved.  Thank you
all on openafs.org that helped us with this issue.  Thank you Derrick for the
key piece of info that has solved this one.

On May 12, 2009, at 6:25 PM, Mark Henry <mark.henry@infoprint.com>

>>> I take it it;'s not likely that something is deleteing files out from
>>> under AFS inside this filesystem?
>> Not that I am aware of.  We did notice that some of the files were
>> missing in
>> one of the system's cache areas.  One of the systems does not have the
>> following files:  CacheItems, CellItems, VolumeItems and the dir lost
>> +found.
>> Mark Henry

Mark Henry

"This message and any attachments are solely for the intended recipient and may contain confidential or privileged information. If you are not the intended recipient, any disclosure, copying, use, or distribution of the information included in this message and any attachments is prohibited. If you have received this communication in error, please notify us by reply e-mail and immediately and permanently delete this message and any attachments. Thank you." _____________________________________________________________________________