[OpenAFS] OpenAFS, Cisco VPN and MAC OS and mtu

Douglas E. Engert deengert@anl.gov
Wed, 27 May 2009 09:52:26 -0500

Kim Kimball wrote:
> Have you tried setting MTU on the fileserver command line instead?

No, and I don't want to. Our problem is with just a few clients using VPNs
I don't want to slow everyone else down.

> That's what we've done, for the same reason.  It has worked, and we 
> don't have to fiddle with each client.  The negotiation between AFS 
> client and fileserver for MTU size is "fileserver wins."

I got a mod working over the weekend, on Ubuntu (openafs 1.4.7) and
MacOS 10.4 with OpenAFS 1.4.10, that adds a -rxmaxmtu option to afsd.
I am putting final touches on it today.

> Kim Kimball
> Douglas E. Engert wrote:
>> We are having problems with Mac OS 10.4 and 10.5  using Cisco VPN
>> AFS can become unusable.  Mac 10.4 is running OpenAFS 1.4.8 for sure.
>> I think the Mac 10.5 is running OpenAFS 1.5.59.
>> Using rxdebug and looking at the natMTU parameter, on most Unix systems
>> this is 1444,(1500 - 56) as expected. On Windows systems this is usually
>> 1260.  And on MAC it is 1444.
>> Even if I set the interface mtu 1244, and reboot the MAC, rxdebug shows
>> the interface is using 1244 but rxdebug continues to show a natMTU = 
>> 1444.
>> as though it still assumed the mtu was 1500.
>> So it looks like the MAC client is not getting the existingMTU
>> from the OS in util/netutils.c
>> The AFS client on Windows has the RxMaxMTU (1244 appears to be the best
>> setting). Is there any equivelent option for the MAC?
>> Any thoughts on this?


  Douglas E. Engert  <DEEngert@anl.gov>
  Argonne National Laboratory
  9700 South Cass Avenue
  Argonne, Illinois  60439
  (630) 252-5444