[OpenAFS] symantec netbackup on Linux

Hoskins, Matthew Matthew.Hoskins@njit.edu
Tue, 1 Sep 2009 20:21:06 -0400

Hey Gary, When we here at NJIT read you post we sort of rolled our eyes.  N=
ot at you, at Symantec.

First off, I cant help you.  But let me tell you why.   (normally I wouldnt=
 reply when I cant help!)

We tried fighting this battle when they first announced that AFS support wa=
s "going away"... Which they did, by way of a appendix buried in the manual=
.   They are dropping support by offering only official support for ancient=
 versions of the software.   Which is useless.  When we called them on this=
, we got nowhere.  We went as high as we could, but in the end, didn't get =
any traction.=20

We are a HUGE Netbackup user, and a HUGE OpenAFS user.   Symantec just does=
n't care.

We are still limping along with using NetBackup 6.0 on Solaris/SPARC.   How=
ever, there are MAJOR problems.  Ever had trouble with restoring incrementa=
l backups?  We essentially have to restore each image as separate jobs.   W=
e have made the decision that we need to dump NetBackup for our OpenAFS cel=
ls.  =20

We are using alternate methods, a form of scripted disk-2-disk vos full and=
 incremental dumps, when then Netbackup picks up and puts on tape.   But on=
e cell (our largest) still remains on NetBackup/Solaris/SPARC.  We havnt be=
en able to get any other platform versions working reliably.   I've tried t=
he RHEL4+5/NetBackup 6 and gave up.=20

-Matt (& the rest of us here at NJIT)

-----Original Message-----
From: openafs-info-admin@openafs.org [mailto:openafs-info-admin@openafs.org=
] On Behalf Of Gary Gatling
Sent: Tuesday, September 01, 2009 3:36 PM
To: openafs-info@openafs.org
Subject: [OpenAFS] symantec netbackup on Linux


Has anyone ever gotten netbackup backup and restore to work with openafs
servers running on Linux? I was able to get restores to work with a 6.0=20
and a 5.1 client. But not backups.

In netbackup I have a file selection for my AFS policy that reads=20

I have been able to backup and restore volumes using netbackup 5.1 MP7,=20
6.0 MP4, and 6.5.4 clients running on SPARC Solaris openafs servers.=20
(openafs version 1.4.11 `cause we just upgraded our servers) But when I=20
try with Linux it just backs up the /vicepa directory like its using a=20
standard policy instead of using vos commands on volumes like it should.

So it backs up all the funny named files under /vicepa/* and when you go=20
to look at the list of what it backed up it opens a dialog saying no files=
match the criteria. The same version of the software on Solaris with=20
AFS backups just works ok.

An example, on Solaris it finds 2 files on my fileserver and backups one=20
of them which is a volume. (I guess the other is the .backup volume) But=20
on Linux with the same basic setup it finds 24 files to backup and they=20
are listed as they are backing up as stuff like:


(So maybe there is some bug in the Linux version of netbackup in the file=20
selection mechanism...)

I am using version 6.5.4 on my test netbackup server.

People here want us to get off of SPARC Solaris but since we are stuck=20
with netbackup as a backup solution it looks like we might be stuck on=20
that platform... Anyone else run into this or find a workaround?

In the Netbackup Systems Administrators guide, volume 2 for 6.0 it says=20
that AFS backups are only supported on Solaris 7, HP-UX 11.0 or IBM AIX=20
4.3.3. platforms. It does seem to work ok with Solaris 10 even though its=20
not officially supported by symantec any longer.

We are running a mix of SPARC Solaris 10 and RHEL 5 in our environment. So=
it would be awesome if there was some way to get AFS backups to work on=20
RHEL 5. We already have a several Linux AFS file servers but they only=20
hold read only volumes so there is no need to back those up.

I was actually suprised that netbackup 6.5.4 on Solaris worked with=20
openafs. Our instructor at the netbackup course told us only old versions=20
of the software would likely work.


Gary Gatling      | ITECS Systems
ITECS, BOX 7901   | Operations and Systems Analyst
NCSU, Raleigh, NC | Email: gsgatlin at eos.ncsu.edu
27695-7901        | (5C Page Hall)
OpenAFS-info mailing list