[OpenAFS] Windows client: "Mount points must be created within the AFS file system".

Anders Magnusson ragge@ltu.se
Fri, 18 Jun 2010 13:12:51 +0200

Jeffrey Altman wrote:
> On 6/18/2010 4:26 AM, Anders Magnusson wrote:
>> Hi,
>> we'we discovered a small bug related to mount points which has appeared
>> in some recent windows client.  Testing with 1.5.74;  mount points
>> cannot be created
>> neither from the explorer shell nor from the command prompt if referring to
>> an UNC path.  This worked with older clients (like 1.5.59).
>> Mapping the afs path to a drive letter and then make a mount point works.
>> It's the UNC path that makes it fail.
>> Is this a known bug or should we file a bug report?
>> -- Ragge
> I just tried:
> [C:\src\openafs\stresstest]fs mkm \\afs\yfs\user\jaltman\dementia
> root.cell -cell dementia.org
> [C:\src\openafs\stresstest]fs lsm \\afs\yfs\user\jaltman\dementia
> '\\afs\yfs\user\jaltman\dementia' is a mount point for volume
> '#dementia.org:root.cell'
> Can you be more specific about the problem you are experiencing?
No problem; H: is my home directory:

H:\>fs mkm AAAA staff.ragge

H:\>fs rmm AAAA

H:\>fs mkm \\afs\ltu.se\staff\r\ragge\AAAA staff.ragge
fs: mount points must be created within the AFS file system

H:\>fs --version

-- Ragge