[OpenAFS] openafs server on freebsd 8.2 amd64: bosserver coredump

Mark mark@nl.simpc.com
Fri, 01 Apr 2011 14:52:14 +0200

Hello all,

We are running a handful of servers on various 32 bit freebsd releases and those are running great.
For our new server we decided on the 64bit version of freebsd (8.2), but things are not going very well.

Bosserver dumps core on all bos requests I tried so far, for the last couple of crashes I checked the coredump and everytime I get a similar backtrace:

(gdb) bt
#0  0x000000080077afcc in kill () from /lib/libc.so.7
#1  0x0000000800779dcb in abort () from /lib/libc.so.7
#2  0x000000000041389b in osi_Panic ()
#3  0x000000000041e3a4 in AllocPacketBufs ()
#4  0x000000000041e465 in rxi_AllocDataBuf ()
#5  0x000000000041ed0b in rxi_ReadPacket ()
#6  0x00000000004145dc in rxi_ListenerProc ()
#7  0x0000000000414815 in rx_ListenerProc ()
#8  0x0000000000423f14 in Create_Process_Part2 ()

Openafs 1.4.14, configure line used:
./configure --enable-transarc-paths --enable-namei-fileserver --with-afs-sysname=amd64_fbsd_80 --enable-largefile-fileserver --disable-pam --enable-supergroups --with-krb5-conf=/usr/bin/krb5-config --disable-kernel-module

Same as our 32 bit servers, with the exception the afs-sysname. During compile we also got an error in src/gtx/curseswindows.c:33, gstty.h does not exist anymore since freebsd 8 and is replaced by termios.h. Replacing the include with the new header completed the build fine.

First we thought the crash was caused by incompatible keyfile format between 32 and 64 bit, since bos listkeys localhost -localauth crashed bosserver, but other bos commands worked. After recreating it with asetkey on the 64bit system listkeys locally works, but doing bos over the network often crashes the server still on the first command or else the next.

Is the server supposed to run on 64bit freebsd 8.2? Or are we better of reinstalling it with 32bit freebsd 8.2?

Mark Huijgen