[OpenAFS] Re: OpenAFS 1.6.0pre4 kernel panic

Ciprian Dorin Craciun ciprian.craciun@gmail.com
Sat, 16 Apr 2011 14:42:46 +0300

On Sat, Apr 16, 2011 at 14:16, Simon Wilkinson <sxw@inf.ed.ac.uk> wrote:
> Could you run gdb against your kernel module (either openafs.ko or libafs.ko), and run
> list *afs_GetDownD.clone.5+0x1d0
> This will let us know exactly where in your kernel module the fault is occurring.
> Cheers,
> Simon

    Unfortunately it complains that it can't find symbols...
gdb ./src/libafs/MODLOAD-
(gdb) list *afs_GetDownD.clone.5+0x1d0
No symbol table is loaded.  Use the "file" command.

    I've tried reconfiguring and rebuilding as below, but with the same result:
./configure         --prefix=/packages/openafs/1.6.0-pre4--1
--with-afs-sysname=i386_linux26         --enable-kernel-module
--disable-transarc-paths         --disable-linux-syscall-probing
      --enable-debug         --enable-debug-kernel

    Have I missed some configuration options, or should I change the
kernel config?