[OpenAFS] Yet another Windows 7 (64 bit) problem: "Listening"

John Tang Boyland boyland@cs.uwm.edu
Wed, 20 Apr 2011 10:04:42 -0500

Dear OpenAFS:

A student just got a new computer running Windows 7 (64 bit)
and has tried to install Openafs:
  OpenAFS 64 bit  | openafs-en_US-64bit-1-5-9904.msi
  Kerberos 64 bit | kfw-amd64-3-2-2.msi

Everything seems to go fine but it's not possible to get tokens:

Output from aklog -d
Authenticating to cell cs.uwm.edu.
Getting v5 tickets: afs/cs.uwm.edu@CS.UWM.EDU
About to resolve name [REMOVED]@CS.UWM.EDU to id
Set username to [REMOVED]@CS.UWM.EDU
Getting tokens.
aklog: ktc 7 (11862791) while obtaining tokens for cell cs.uwm.edu

NET VIEW \\AFS [press enter and the following displays]

shared resources at \\afs

Share name Type Used as Comment
Users   Disk
The command completed successfully.

nbtstat -s (shows all sessions in a table with destination IP)

Local Name      State    In/Out  Remote Host       Input   Output
AFS            Listening

nbtstat -n (shows all local netbios names) has AFS as a network connection
(all together there is Local area connection 1,2 and AFS).

This is after a reboot (to avoid the known Windows 7 bug.)
We've tried disabling and re-enabling the Loopback adapter to no avail.