[OpenAFS] Status of OS X 10.6 64bit kernel support ?

Chris Jones jonesc@hep.phy.cam.ac.uk
Fri, 21 Jan 2011 15:41:16 +0000


Thanks, I'll do that.

cheers Chris

Jeffrey Altman wrote:
> Chris:
> Derrick already replied to you and he is one of the gatekeepers and
> primary developers for MacOS X.  What you can do is file a bug report at
> openafs-bugs@openafs.org so this issue does not get lost.  I suspect
> what someone is going to have to do is replicate your environment and
> attempt to reproduce the issue.
> Jeffrey Altman
> On 1/21/2011 9:41 AM, Chris Jones wrote:
>> Hi,
>> Just thought I would ping this report, to see if anyone else has any
>> other ideas ?
>> I need to run the 64bit kernel, as have updated my MacBook Pro to 8GB
>> ram, and I need to run the 64 bit kernel to properly support this. AFS
>> is so slow it is effectively unusable in this case. I can live without
>> AFS but it would be very nice to get it usefully working again.
>> Would this be an appropriate thing to ask on the devel list ?
>> cheers Chris
>> Chris Jones wrote:
>>> Hi,
>>> It doesn't seem to help. navigating around in afs is just a lot lot
>>> slower and less responsive when in the 64 bit kernel, compared to the
>>> same operations when running the 32 bit kernel. Eventually they do
>>> work, they just take a long long time.
>>> One thing in particular that seems to show the problem is just
>>> repeatedly running 'ls' in the same AFS directory. With the 32 bit
>>> kernel the first time I run this (after a reboot) might take a short
>>> while to complete (presumably whilst the cache is being refreshed) but
>>> subsequent runs are essentially instantaneous. With the 64 bit kernel
>>> this is not the case. Each time I run ls in the same dir, it takes the
>>> same long time (order minutes) to complete.
>>> cheers Chris
>>>> On Wed, Jan 12, 2011 at 4:52 PM, Chris Jones
>>>> <christopher.rob.jones@cern.ch> wrote:
>>>>> Hi,
>>>>> I am running the 1.5.78 feature release of openafs on OS X 10.6.X
>>>>> (currently 10.6.6).
>>>>> When running with the default 32 bit kernel, all seems to work fine.
>>>>> However, if I switch to the 64 bit kernel (which I would like to do
>>>>> for other reasons) openafs seems to experience problems. Accessing
>>>>> afs directories (under /afs/cern.ch, if that matters) seem to just
>>>>> hang up, without ever accessing the AFS file system. The same
>>>>> operations using the 32 bit kernel do not show these same hang ups.
>>>>> I have searched the Console messages, but not spotted anything (to
>>>>> my uneducated eye) that relate to afs.
>>>>> I understand that the OS X 64 bit kernel is currently not the
>>>>> default on desktop systems, so I was just wondering what the status
>>>>> was, and if there where any known issues with this kernel and openafs ?
>>>>> If I haven't provided enough details, please just ask.
>>>> one bug was fixed since then, at least from memory. try 1.6.0pre1?
>>>> -- 
>>>> Derrick
>>> _______________________________________________
>>> OpenAFS-info mailing list
>>> OpenAFS-info@openafs.org
>>> https://lists.openafs.org/mailman/listinfo/openafs-info
>> _______________________________________________
>> OpenAFS-info mailing list
>> OpenAFS-info@openafs.org
>> https://lists.openafs.org/mailman/listinfo/openafs-info