[OpenAFS] is k5start command not functional at 1.4.12-79 version?

Jonathan Nilsson jnilsson@uci.edu
Thu, 27 Jan 2011 13:31:46 -0800

Well, no one has replied to you yet, so I'll give it a shot.  Though I'm by no 
means an expert.

> i was able to use the k5start command at the openafs-1.4.7-68.
> somehow, i updated the kernel version from 2.6.18-92.1.6 to
> 2.6.18-92.1.22 and update the openafs from 1.4.7-68 to 1.4.12-79.

My versions are different from yours, so this is just a data point:

CentOS 5.5 32-bit
openafs-client 1.4.12-el5.1.1
k5start 3.16 (configured with --disable-k4start)

> k5start -l 5d -tUf /opt/tivoli/tsm/client/ba/bin/tsm.keytab -- sh -c
> '/opt/tivoli/tsm/client/ba/bin/dsmc incremental'

I do not have tivoli installed, so I can't confirm that this would necessarily 
work for you, but other scripts that I have, notably an rsnapshot backup script, 
do work when I wrap them like this:

/usr/bin/pagsh -c "/usr/local/bin/k5start -K 30 \
-p /var/run/k5start-backup.pid -bLtUf /etc/mybackupscript.keytab; \
/usr/local/bin/rsnapshot-wrapper.sh daily; \
kill `cat /var/run/k5start-backup.pid`;"

I do it this way because some scripts that I have fork and all the processes 
need to share the same PAG.  Not sure if there is a better way to do that.

I also recompiled k5start with --enable-setpag and then tried passing the 
command to run directly to k5start:

/usr/bin/k5start -l 5d -tUf /etc/mybackupscript.keytab \
-- sh -c '/usr/local/bin/rsnapshot-wrapper.sh daily'

and that worked.

best of luck!