[OpenAFS] Volume missing

Douglas E. Engert deengert@anl.gov
Thu, 01 Sep 2011 15:09:38 -0500

On 9/1/2011 2:33 PM, vitor lima wrote:
> Hello!
> I have a problem with a openafs volume:
> I moved the volume user.w from the server1 to server0, but the user had some problems to log in,
> then, I moved the volume to server0 again.

It is still not clear if you have 1 or two database servers.
One of the severs may think the cell has only 1 database server
but the thinks the cell has 2.

What do you think your cell should look like now?
i.e. what machines have database servers, what machines
are file servers.

Depending on which client you run the vos listvol command
it might be talking to one or the other server.

After you changed around all the CellServDB files, did you stop
the data base processes on the server you removed?

What do these commands show:

Run from any machine:
  bos status server0.cell.name
  bos status server1.cell.name

  bos listhost server0.cell.name
  bos listhost server1.cell.name

Run from server0:
   vos listvol server0.cell.name
   vos listvol server1.cell.name

Run from server1:
   vos listvol server0.cell.name
   vos listvol server0.cell.name

> But the volume simply disappeared
> O.o
> When I run
> vos listvol
> it is not listed.
> When I run
> vos listvldb
> I have
> "user.w
>      RWrite: 536870948
>      number of sites -> 1
>         server server1.cell.name <http://server1.cell.name> partition /vicepa RW Site"
> What can be this?
> Thank you very much.


  Douglas E. Engert  <DEEngert@anl.gov>
  Argonne National Laboratory
  9700 South Cass Avenue
  Argonne, Illinois  60439
  (630) 252-5444