[OpenAFS] Re: problem with dbservers running under bosserver

Kevin Coffman kwc@citi.umich.edu
Wed, 15 Feb 2012 18:51:37 -0500

On Wed, Feb 15, 2012 at 5:49 PM, Andrew Deason <adeason@sinenomine.net> wro=
> On Wed, 15 Feb 2012 17:30:30 -0500
> Kevin Coffman <kwc@citi.umich.edu> wrote:
>> 1) When I try and run any ubik servers under the bosserver, they fail
>> to start with
>> vlserver: Ubik init failed: file not found when processing dbase
>> ptserver: file not found when processing dbase Ubik init failed
>> However, if I run the vlserver or ptserver directly from the command
>> line, they appear to run fine and communicate with the 1.4 machine.
> Well it's easy enough to see what they're failing on if you run them
> under strace. mv vlserver to vlserver.real, and make vlserver just
> something like (make sure to 'chmod a+x' it):
> #!/bin/sh
> strace -f -o /tmp/whatever$$.dmp -- /usr/afs/bin/vlserver.real "$@"
>> 2) The bosserver appears to read /usr/afs/local/BosConfig, but does
>> not (will not) write it. =A0I've verified that it will bail out if there
>> is an error in the BosConfig file. =A0However, if I try to do any
>> commands that should alter it, they either fail, or skip the writing
>> part..
> Try strace'ing bosserver when you do this?

Thanks, this pointed me in the right direction.

Everything worked while strace'ing the bosserver.  I changed SELinux
to "Permissive" mode and everything now works while running from the
init script.

Any SELinux experts out there that can point me at how to fix things
up so SELinux is happy?  (I'll run in permissive mode for now!)