[OpenAFS] Re: creating and deleting user accounts

Andrew Deason adeason@sinenomine.net
Wed, 29 Feb 2012 00:48:09 -0600

On Tue, 28 Feb 2012 20:22:31 -0500
"Lewis, Dave" <LEWIS@NKI.RFMH.ORG> wrote:

> Last night when I created the user account, I got "No such device"
> errors when trying to access the home directory on some computers.
> The errors remained after I did syncvldb and syncserv and after I ran
> fs flush commands.  But when I checked this morning, there were no
> errors accessing the home directory.

As part of removing/recreating the user, you removed the user.moe
volume, and created the volume again, which gives the volume a different
volume id number. The client caches volume lookups for 2 hours, so the
client thought that the volume still existed under the old id, so it
could not access the volume contents. And when you tried to access it
more than 2 hours later, the client looked up the volume information
again and got the correct volume id, so it all seemed fine.

If you ran 'fs checkv' after deleting the account, it probably would
have worked.

Andrew Deason