[OpenAFS] Re: RClone - Volume already exists

Andrew Deason adeason@sinenomine.net
Tue, 15 Oct 2013 10:08:25 -0400

On Tue, 15 Oct 2013 11:37:50 +0000
Nicolas DEFFAYET <nicolas-ml@deffayet.com> wrote:

> I have troubles with some volumes during the vos release:
> # vos release backups -verbose -localauth

What version of OpenAFS is 'vos'? What version is the volserver?

> backups 
>     RWrite: 536870926     ROnly: 536870936     Backup: 536870946
> RClone: 536870936 
>     number of sites -> 2
>        server primary partition /vicepa RW Site  -- New release
>        server secondary partition /vicepa RO Site  -- Old release
> This is a complete release of volume 536870926
> Cloning RW volume 536870926 to temporary RO...Failed to clone the RW
> volume 536870926
> Volume already exists
> Error in vos release command.
> Volume already exists

What's happening here is that the volserver said "volume 536870936
doesn't exist", and when we tried to clone to volume 536870936, the
volserver said "you can't do that, because 536870936 already exists".
At least, that is what it means with newer versions, I'm not sure if
various older versions are in play.

So of course, that's a little confusing. Can you run on the 'primary':

# ls -l /vicepa/V0536870936.vol
# volinfo /vicepa 536870936

volinfo may be in /usr/afs/bin, if you can't find it. And can you look
in VolserLog and FileLog on "primary" to see if new messages appear when
you try to perform the release? Can you try salvaging the volume
536870926 on "primary", and provide what SalvageLog says? (or SalsrvLog
if you are running DAFS)

> Ted have reported a problem of RClone
> (http://lists.openafs.org/pipermail/openafs-info/2012-May/038225.html),
> the feedback from Andrew was:
> "That usually appears after an interrupted volume release. It should
> stop being displayed after you release the volume successfully, or
> delete it, etc."

I don't think he was asking about an issue with it (unless there were
further emails involving an issue; I'm just skimming that), he was just
asking what the RClone field means / why it's there. So that explanaiton
is about the RClone field appearing, not about an error.

> -> -f flags don't fix the issue, same error "Volume already exists" It
> seem that the flag doesn't exist with OpenAFS and so no effect when
> trying to use it.

It certainly does exist in OpenAFS; if that option didn't exist, you'd
get an error that the option doesn't exist :) It just doesn't help with
this issue, because we are failing before -f/-force makes a difference.

Andrew Deason