[OpenAFS] OpenAFS installation messes up Windows 8 file access control

Tim Adye T.J.Adye@rl.ac.uk
Sun, 15 Sep 2013 21:08:29 +0100


The OpenAFS client installation is doing something nasty to the file access
control on my Windows 8 system. After installing OpenAFS, I can no longer
move, copy, or delete files with the File Explorer in local Windows folders
that require administrator privileges. 

What should happen, and happens again if I uninstall OpenAFS, is that I get
a pop-up message such as "File Access Denied: You'll need to provide
administrator permission to copy to this folder". I can then then select
"Continue" (perhaps needing an admin password) to copy the file.

When OpenAFS is installed, there is no pop-up message and the copy silently
fails. This occurs with drag-and-drop and Ctrl/C+X+V copy and move, and
deleting with the "Delete" key or button. Oddly, the pop-up message does
appear when creating or renaming a file or folder, so those operations still
work. It is also possible to delete files from the context menu (which show
the admin icon and don't normally require confirmation).

This is a problem with Windows Explorer (now called File Explorer in Windows
8) and seemingly nothing to do with OpenAFS, except that it occurs whenever
OpenAFS is installed. I can fix the problem by uninstalling OpenAFS, and the
problem comes back when I reinstall OpenAFS. I tried disabling all the
OpenAFS components with "autoruns" (and restarting), but the problem
remained. So I guess it is some change made by the OpenAFS installation
program. What changes does it make to the Windows Account Control and
authorisation systems that might cause such an issue? I tried comparing
registry dumps before and after uninstalling OpenAFS, but didn't see
anything obvious.

I used the standard OpenAFS IFS install and all the default options (all
enabled, except integrated login), but it didn't help to disable the rest.

I am using 64-bit Windows 8 Standard Edition (so I can't check for user or
group policy changes, since that control panel requires Windows 8 Pro). I
installed 64-bit OpenAFS 1.7.2600, but had the same problem with an older
version, 1.7.0800, that does not give me this problem on a Windows 7 Pro
system. So, it could be Windows 8 (vs 7) or Standard Edition (vs Pro).

Does anyone have any ideas? I would be very grateful for any fix or
work-around. With OpenAFS installed, it is extremely cumbersome to make any
program file changes on my system. The only way I have to copy or move
program files in Windows Explorer is by taking ownership and changing the
permissions on all directories and files involved, making the move, and
restoring the original permissions - a cumbersome and risky operation. Or
else to do everything from the command-line from an Admin account.


===========================  cut here  ============================
 Tim Adye      T.J.Adye@rl.ac.uk       http://hepunx.rl.ac.uk/~adye
 ATLAS Group,  Particle Physics Dept,  Rutherford Appleton Lab

Scanned by iCritical.