[OpenAFS] Naming of "backup" and "up" commands

Ken Dreyer ktdreyer@ktdreyer.com
Sun, 22 Sep 2013 19:53:51 -0600

On Sun, Sep 22, 2013 at 6:51 PM, Russ Allbery <rra@stanford.edu> wrote:
> In the Debian packaging for OpenAFS, I've renamed the "up" command to
> "afs-up" for years now.  There's now also a conflict with the "backup"
> command (which is a horrible name for a command), and I'm rather tempted
> to do the same thing, but since it's a whole command suite with multiple
> documentation pages and cross-references, it's more of an undertaking.
> What would people think if I submitted a patch to OpenAFS to rename up to
> afs-up and backup to afs-backup?  Would that break a bunch of critical
> software?  It would be really nice to fix AFS's camping on obvious
> namespace.

There is an open bug regarding the "backup" command name:


At the time, the conclusion was to rename the command "afsbackup".

I completely agree that it should be renamed.

- Ken