[OpenAFS] Re: Naming of "backup" and "up" commands

Christof Hanke christof.hanke@rzg.mpg.de
Mon, 23 Sep 2013 09:19:07 +0200

[added release-team] 

On Sun, 22 Sep 2013 23:42:55 -0500
Andrew Deason <adeason@sinenomine.net> wrote:

> On Sun, 22 Sep 2013 17:51:40 -0700
> Russ Allbery <rra@stanford.edu> wrote:
> > What would people think if I submitted a patch to OpenAFS to rename up
> > to afs-up and backup to afs-backup?  Would that break a bunch of
> > critical software?  It would be really nice to fix AFS's camping on
> > obvious namespace.
> Would it be appropriate to also have an optional compat package that
> could symlink the original names?
yes, I think so.
Thing is, for SuSE I renamed scout to afs_scout.
I'm not sure if RedHat/SL did some similar renaming 
(probaly using yet another scheme for it)

So, on possible solution is to 
fix the renaming on gerrit.
Then the packagers can create their own compatibility packages for this, 
since they are sure of the future binary-names.

> Either way, sure, makes sense to me. But the people that actually use
> those commands really do need to say something, even if it's just "yes,
> sounds good".