[OpenAFS] Re: vos move operation stalls

Volkmar Glauche volkmar.glauche@uniklinik-freiburg.de
Thu, 10 Apr 2014 09:57:16 +0200

Hi all,

I just want to post what seems to be the solution for this issue:
Apparently, the problem was not with OpenAFS, but with the options I
used when creating the filesystem.
I used XFS "su" and "sw" options to match the geometry of my hardware
RAID. Apparently the default size for the log section of 512 blocks
wasn't big enough for my setup. However, there was no obvious warning
during filesystem creation, and the filesystem got mounted without
errors with Linux kernel 3.8. As part of my debugging activity, I also
tried kernel 3.12, which has a new XFS_WARN config option. This produced
a warning at mount time that the log section of the filesystem might be
too small. Increasing the log section size during filesystem creation to
3200 blocks seems to solve the problem.



Am 25.03.2014 17:05, schrieb Andrew Deason:
> On Mon, 24 Mar 2014 13:47:33 +0100
> Volkmar Glauche <volkmar.glauche@uniklinik-freiburg.de> wrote:
>> I have installed a new fileserver, running Gentoo Linux, kernel 3.8.13,
>> OpenAFS 1.6.5 (also tried 1.6.6). The server has two /vicep partitions,
>> each with an XFS filesystem:
> You filed this under
> <https://rt.central.org/rt/Ticket/Display.html?id=131825>; sorry, I've
> been meaning to reply to that but this is a particularly busy week. I'm
> going to just correspond through that ticket instead of here, but if
> people want to continue the conversation in -info, then go ahead.