[OpenAFS] Linux find command inconsistent

John Sopko sopko@cs.unc.edu
Tue, 15 Sep 2015 11:46:13 -0400

I run a monthly report to find all mount points and volumes using the
linux find command. I used to run this on Red Hat 5 for years. I moved
the script to Red Hat 6 and found after testing that on Red Hat 6 and
7 and Ubuntu 14.04 the find command give inconsistent results and does
not find nearly as many files as Red Hat 5 does.

I can copy the Red Hat 5 find binary to Red Hat 6 which executes ok
but still has a problem. I tried serveral client machines.

For example on Red Hat 5 I run a command to find all directories and count them:

% lsb_release -d
Description:    Red Hat Enterprise Linux Client release 5.11 (Tikanga)

 |sopko@kramer:56% pwd

% find . -noleaf -type d | wc -l

On Red Hat 6 I get:

% lsb_release -d
Description:    Red Hat Enterprise Linux Workstation release 6.7 (Santiago)

 |sopko@lark1:81% pwd

 |sopko@lark1:82% find . -noleaf -type d | wc -l
find: `./par/Last_Backup/Last_Backup': No such device

I also like to use the find command to set afs acl's on directories
but can not trust it to work.

I am running 1.6.11 on the servers, 1.6.9 on the rhel5 client and
1.6.11 on the rhel6 client and 1.6.14 on Ubuntu. Can anyone shed any
light on what is going on?

John W. Sopko Jr.
University of North Carolina
Computer Science Dept CB 3175
Chapel Hill, NC 27599-3175

Fred Brooks Building; Room 140
Computer Services
email: sopko AT cs.unc.edu
phone: 919-590-6144