[OpenAFS] compile fails kernel version 4.4.0-1-default

mdrslmr mdrslmr@online.de
Wed, 9 Mar 2016 08:56:35 +0100 (CET)

  This message is in MIME format.  The first part should be readable text,
  while the remaining parts are likely unreadable without MIME-aware tools.

Content-Type: text/plain; charset=UTF-8; format=flowed
Content-Transfer-Encoding: QUOTED-PRINTABLE


On Tue, 8 Mar 2016, Michael La=C3=9F wrote:

> Was the error code 32 returned from git or did the kernel log message
> change accordingly? Does your log again show a lost file server
> connection? And have files been corrupted or just the checkout aborted?

Now I tried a couple times again with the patch and this time I once found =
error -512.

The output in the terminal running git looks like this:

error: unable to unlink old 'src/afs/Makefile.in' (Connection timed out)

=2E.. about 20 more messages like the above one

fatal: cannot create directory at 'src/afs/NBSD': Connection timed out
warning: unable to unlink
=2Egit/index.lock: Connection
timed out
fatal: Not a git repository (or any parent up to mount point /afs)

The log messages look like this:

Mar 09 08:42:45  kernel: afs: Lost contact with file server in cell desy.de (code -512) (all multi-homed ip addresses
down for the server)
Mar 09 08:42:45 kernel: afs: failed to store file (network
Mar 09 08:42:46 kernel: afs: file server in
cell desy.de is back up (code 0) (multi-homed address; other same-host
interfaces may still be down)

For some cross checking:
This morning I used a backup partition of my archlinux installation
which still has kernel 4.3. The backup was last updated on 2016-01-07
(pacman -Syu). On this installation I tried to provoke the above
error. But everything went well for about 20 tries.
This may only serve to confirm that no changes outised my computer
(servers, network, ..) cause my problems.