OpenAFS Master Repository branch, master, updated. openafs-devel-1_5_74_1-168-g5f2c6bd

Gerrit Code Review gerrit@openafs.org
Thu, 27 May 2010 19:52:49 -0700 (PDT)


The following commit has been merged in the master branch:
commit 5f2c6bd341674618d14658d0f642465b0f0259b9
Author: Russ Allbery <rra@stanford.edu>
Date:   Wed May 26 23:23:10 2010 -0500

    Add k_haspag to libkopenafs
    
    Add the k_haspag function to libkopenafs, which returns true if the
    current process is in a PAG and false otherwise.
    
    The implementation currently duplicates code from the ktc_curpag
    function since the latter calls the regular pioctl() interface and
    hence introduces an Rx dependency that we're avoiding for libkopenafs.
    This should be refactored to avoid the code duplication at some point,
    but that will require building a utility library that can be reasonably
    linked into libkopenafs and is therefore deferred for future work.
    
    Change-Id: Ib97322ef24dc3a4e48cb45090c516c95b71e9fc7
    Reviewed-on: http://gerrit.openafs.org/2041
    Reviewed-by: Derrick Brashear <shadow@dementia.org>
    Tested-by: Derrick Brashear <shadow@dementia.org>

 src/kopenafs/Makefile.in     |    2 +-
 src/kopenafs/kopenafs.c      |  111 ++++++++++++++++++++++++++++++++++++++++-
 src/kopenafs/kopenafs.h      |    6 ++
 src/kopenafs/libkopenafs.map |    1 +
 src/kopenafs/test-setpag.c   |    7 +++
 5 files changed, 123 insertions(+), 4 deletions(-)

-- 
OpenAFS Master Repository