OpenAFS Master Repository branch, master, updated. openafs-devel-1_5_76-4392-g119d2ed
Gerrit Code Review
gerrit@openafs.org
Wed, 8 Oct 2014 10:52:18 -0400
The following commit has been merged in the master branch:
commit 119d2edf8a4b42ca4c3fd36d17e3621ddc0de60d
Author: Benjamin Kaduk <kaduk@mit.edu>
Date: Mon Sep 22 17:02:27 2014 -0400
Allow building with MIT krb5 and external roken
That is, an external roken which is part of a heimdal distribution,
with full headers and libraries, most notably krb5.h and libkrb5.
This adjusts the ordering of file- and module-specific compiler and
linker arguments so that the more specific arguments are able to
take precedence. For general flags arguments, such as enabling
or disabling warnings or features, the more-specific settings should
come last, so as to override the flags set by default. However,
for arguments that affect a global search list (e.g., for headers
or libraries), the more-specific arguments must come first, so
as to be at the beginning of the search list.
We presently use per-file CFLAGS for both warning-type flags and
preprocessor (i.e., include path) type flags, so add an additional
file-specific setting for CPPFLAGS, which comes at the beginning of
the compiler invocation.
At present, MODULE_CFLAGS are essentially only used for preprocessor
functionality, so treat them as CPPFLAGS and put them right after
the per-file CPPFLAGS. (It might be cleaner to rename them to
MODULE_CPPFLAGS, but that would be more churn than is needed. If
such a distinction turns out to be necessary, it can be done at a
later date.) Likewise the MODULE_LDFLAGS are generally being used
to affect the library search path, so put them early as well.
Make the necessary Makefile changes to use these new features to
allow building with MIT krb5 and external roken: put KRB5_CPPFLAGS
in per-file CPPFLAGS, and put LDFLAGS_KRB5 in MODULE_LDFLAGS for
aklog.
Change-Id: I1091223b3b75c782b39b9e189bdd47e52ebefae2
Reviewed-on: http://gerrit.openafs.org/11474
Reviewed-by: Benjamin Kaduk <kaduk@mit.edu>
Reviewed-by: D Brashear <shadow@your-file-system.com>
Tested-by: D Brashear <shadow@your-file-system.com>
src/aklog/Makefile.in | 1 +
src/config/Makefile.config.in | 28 ++++++++++++++--------------
src/libafscp/Makefile.in | 6 +++---
src/tsm41/Makefile.in | 2 +-
src/venus/Makefile.in | 2 --
5 files changed, 19 insertions(+), 20 deletions(-)
--
OpenAFS Master Repository