[OpenAFS] /afs: Not a directory

Marc Schmitt schmitt@inf.ethz.ch
Mon, 03 Dec 2001 18:14:50 +0100

Hi Tino,

I made the experience that under older versions of AFS, the mount point 
/afs will be created once the daemon is started. I just upgraded one of 
my machines from 1.1.1-24.4 to 1.2.2-rh7.1.1 and after the reboot, the 
AFS daemon would start (no errors at all), but ls -la /afs comes back with
/afs: Not a directory

lsmod shows:

Module                  Size       Used by
libafs-something        somesize    0

The used by 0 indicates that something is wrong. rmmod libafs-something 
gives a panic (always).

What I did is "mkdir /afs" and reboot, everything worked fine afterwards 
(used will show 2 instead of 0 (depends on kernel version, I think, 
under 2.2 it shows 1, under 2.4 2)).



Tino Schwarze wrote:

> Hi there,
> I don't know where to look next. I already told about my problems after
> upgrading to 1.2.2. Now I rebooted, cleaned the client cache and it
> still says: 
> /afs: Not a directory
> Everything takes place on the same machine, no other clients are
> running.
> I tried to salvage and got lots of errors (SalvageLog attached.)
> A bit later I got an Oops (ksymoops output appended); just before the
> Oops found "kernel: IPUT Bad refCount 0 on inode 0xc8c87000".
> Any hints?
> Bye, Tino.