[OpenAFS] 'diskless' clients with AFS in Linux initrd

Jeffrey Hutzelman jhutz@cmu.edu
Mon, 17 Dec 2001 10:36:39 -0500 (EST)

On 14 Dec 2001, Derek Atkins wrote:

> Jeffrey Hutzelman <jhutz@cmu.edu> writes:
> > I also have no confidence at the moment that AFS still works in the initrd
> > environment.  While an initrd is in use, kernel startup has not completely
> > finished.  I used to support installing RedHat systems via AFS, but had to
> > stop doing that with RH7.1 when AFS stopped working in the initrd
> > environment. 
> Can you comment on how AFS stopped working in the initrd environment?
> MIT/Athena certainly installs a RH7.1-based system via AFS (although
> I don't know if it uses an initrd or some other method).

First, I don't think Athena 9.0 workstations are installed using memcache,
since that apparently doesn't work at all on 2.4.x kernels.

Second, it seems that the last time my AFS-install worked was on RH5.2; on
transitioning to 6.2 I discovered thatmemcache no longer worked in the
initrd environment in which RedHat's installer runs.

-- Jeff