[OpenAFS] 'diskless' clients with AFS in Linux initrd

Derek Atkins warlord@MIT.EDU
17 Dec 2001 11:27:01 -0500

Jeffrey Hutzelman <jhutz@cmu.edu> writes:

> > Can you comment on how AFS stopped working in the initrd environment?
> > MIT/Athena certainly installs a RH7.1-based system via AFS (although
> > I don't know if it uses an initrd or some other method).
> First, I don't think Athena 9.0 workstations are installed using memcache,
> since that apparently doesn't work at all on 2.4.x kernels.

Ahh, you had not specified memcache...

> Second, it seems that the last time my AFS-install worked was on RH5.2; on
> transitioning to 6.2 I discovered thatmemcache no longer worked in the
> initrd environment in which RedHat's installer runs.

I thought you could still use a ramdisk cache, no?  Anyways, it's
not really important.

> -- Jeff


       Derek Atkins, SB '93 MIT EE, SM '95 MIT Media Laboratory
       Member, MIT Student Information Processing Board  (SIPB)
       URL: http://web.mit.edu/warlord/    PP-ASEL-IA     N1NWH
       warlord@MIT.EDU                        PGP key available