[OpenAFS] 1.2.10 build problems on 'linux from scratch'

Kevin Coffman kwc@citi.umich.edu
Tue, 26 Aug 2003 17:34:41 -0400

I'm having problems building 1.2.10 on a linux machine built from 
scratch (i.e not a redhat or debian distribution).  It is running the 
2.4.20 kernel from kernel.org.  I should first note that I built a CVS 
snapshot from about a month ago on 'this' machine w/o these problems.  
So I guess I'm really hoping someone can point me to the changes that I 
need to apply to fix the problem(s).

First some info on the system:

-bash-2.05b$ uname -a
Linux xxxx.umich.edu 2.4.20 #5 SMP Thu May 29 01:16:34 EDT 2003 i686 
unknown unknown GNU/Linux

During configure, I ran into the same problem mentioned in this thread:


After commenting out the error in the configure script as suggested in 
the final message of the thread, configure completed.  However, now I 
think I'm running into the consequences of that with the following 
error during the make:

gcc  -O2 -fomit-frame-pointer -fno-strength-reduce -fno-strict-aliasing 
-fno-common -pipe -march=pentium -D__KERNEL__  -DCPU=586 -DKERNEL 
-D_KERNEL -DMODULE -DAFS_SMP    -I. -I../ -I/home/kwc/build/openafs-1.2.
10/src/config -c ../afs/osi_module.c
../afs/osi_module.c: In function `afs_init':
../afs/osi_module.c:325: `sys_exit' undeclared (first use in this 
../afs/osi_module.c:325: (Each undeclared identifier is reported only 
../afs/osi_module.c:325: for each function it appears in.)
../afs/osi_module.c:327: warning: assignment from incompatible pointer 
make[4]: *** [osi_module.o] Error 1
make[4]: Leaving directory `/home/kwc/build/openafs-1.2.10/src/libafs/MO
make[3]: *** [linux_compdirs] Error 2
make[3]: Leaving directory `/home/kwc/build/openafs-1.2.10/src/libafs'
make[2]: *** [libafs] Error 2
make[2]: Leaving directory `/home/kwc/build/openafs-1.2.10'
make[1]: *** [build] Error 2
make[1]: Leaving directory `/home/kwc/build/openafs-1.2.10'
make: *** [all] Error 2
-bash-2.05b$ ls             

The kernel header files are located in /usr/include/linux and I have 
specified './configure --with-linux-kernel-headers=/usr' which is what 
worked when building the cvs snapshot.  This is not the machine where 
the kernel was built, but the headers are 'guaranteed' to match the 
kernel I'm running.

Any suggestions?